Relayer stuck on omega omega evm
Incident Report for Omni Network
Resolved
This incident has been resolved.
Posted Nov 27, 2024 - 02:30 UTC
Investigating
We are currently investigating this issue.
Posted Nov 26, 2024 - 21:02 UTC