Partial Outage on Public RPC Endpoints

Incident Report for Omni Network

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 10:14 UTC

Investigating

We're currently investigating an issue affecting some of our public RPC endpoints.

The mainnet RPC remains fully operational: https://mainnet.omni.network/
Posted Jun 12, 2025 - 07:00 UTC